Need help diagnosing glitches with MOTU 896HD

Posted on

Member Since: Mar 26, 2009

Hey all,

So I'm doing some recording for some of the bands that I'm in, doing demos and the like. I appreciate the sound quality of my MOTU 896HD but I am plagued by take-ruining glitches in recording. Sometimes they happen, sometimes they don't, making every take a gamble for success.

I am currently continuing my research on what the root of the problem may be. Here is my current setup:

- Gateway T-1625 Laptop running Windows 7 (had the same problem on Vista): 2gb RAM, 250GB hard drive, 2.0GHz dual-core AMD, AMD M690T chipset (also seen it listed as ATI RS690T), ATI x1270 integrated video
- MOTU 896HD
- Dynex DX-EFCW FireWire ExpressCard (1x800, 1x400)
- Sonar 7 Producer
- Sometimes my 320GB USB 2.0 external HD

Right away I of course suspect the Dynex as causing the problem. However, I did notice the glitch, just once, when I connected to my friend's giant Dell XPS tower. It did seem more stable, but I did hear that one glitch on playback.

Note that the sound that occurs can happen either on recording or on playback. If it happens while recording, I don't hear anything while tracking but of course it is printed on tape. Whenever I hear it on playback I always have to rewind to check and see if the noise is on tape. This behaviour leads me to suspect the MOTU.. I'm really hoping this isn't it.

I've investigated PCI bus latency of my video card (currently at 64). Later today I'm going to wipe this system and do a fresh dual-boot install of XP and Win 7 (the current Win7 was installed over the top of my Vista factory install).

I have a sound clip that I'd like to post here of the noise that I hear, which I think would be the most helpful part of this. Can I do this in this forum?


[ Back to Top ]

Since: Mar 26, 2009

Mar 26, 2009 03:45 pm

PS - Here is the ExpressCard that I would likely order as a replacement:

Czar of Turd Polish
Since: Jun 20, 2006

Mar 26, 2009 03:51 pm

Yes you can post songs\sounds under your profile (song management).

Also, turn of wireless if you have it. It's a shot in the dark but definitely something I have experienced personally. It caused hiccups (no sound) at times and would sometimes keep tracking but there would be no signal. Turned off, never saw it again.

Since: Mar 26, 2009

Mar 26, 2009 04:30 pm

Ok, thanks for the info. I posted into my profile a short clip of the sound that I get.

It sounds to me as though either something is taking over the FireWire bus, or the card itself is performing some internal routine which stalls data transfers, or my MOTU unit is bunk. In addition to this type of sound, it sometimes 'skips' a fraction of a second, and sometimes it sounds more like snazzzllllPOPfizzz, with a large high frequency component (squeak).

I fear the MOTU more and more because I never experience dropouts - i.e. SONAR doesn't halt - while recording, so the data bus seems unaware of the issue.

What do you guys think? Recognize anything?

Thanks again.

Since: Mar 26, 2009

Mar 26, 2009 04:33 pm

As far as disabling wireless, I've tried that. Thanks for the suggestion. I've also been experimenting now with turning off every single non-essential device in Device Manager. I also am running DPC Latency Checker, which interestingly displays an increase in the DPC latency from average 50us to average 800us anytime an app that is using the MOTU ASIO drivers is running as the main focus window. I suppose this is normal?

Czar of Midi
Since: Apr 04, 2002

Mar 26, 2009 05:09 pm

I'll be back with a couple question's later, but don't be too hasty to put blame on the MOTU as bunk. It could be a few other things as well.

Have you checked to see what the latency buffer is set at? I'm thinking it might be too low and causing the hic up.

But as well I have seen that particular card have issues with MOTU before.

Is it a 6 pin or 4 pin card?

Also, are you using a power supply with the MOTU and not powering it off the Firewire buss?

Since: Mar 26, 2009

Mar 26, 2009 06:07 pm

Yeah, I'm hoping it's not the MOTU. I checked the MOTU Control Panel, and the Samples Per Buffer is set to 1024 currently. The Firewire card is is 6-pin for the FW400 slot. The MOTU is running off of its built-in transformer, with a dedicated 3-prong power cord.

I had one more thought - I've been running the ASIO drivers because I assumed them to be the best. I know that MME and WDM would have more latency, but then I can use the CueMix software to sidestep that issue. Might it be a good idea to try MME or WDM modes? I need stability more than I need low latency.

Czar of Midi
Since: Apr 04, 2002

Mar 26, 2009 07:50 pm

I would suggest trying the WDM as it is almost an equal to ASIO, not as good but still capable of pretty low latency.

Don't even bother with the MME as that is an emulated driver and very generic. You probably would be really lucky to get any better then 150 ms of latency out of it.

In Sonar in the Audio/Options page what is showing for latency now?

I believe you should have a setting called out as ASIO buffer size or something along that line. It should be set usually around 128, 256 or even out to 512 at times. But your setting of 1024 would be the next step so I am thinking that is the correct buffer. Try just for kicks moving it down to 512 or 256 would be even better.

I'm just wondering if the buffer is set far to high and causing issues.

As I said, I normally run 128 and get a latency of about 3 ms or so.

Czar of Midi
Since: Apr 04, 2002

Mar 26, 2009 07:58 pm

OK, I just got to listen to the sample you put up.

That sounds like something I've heard when the buss drops out or is having comm. issues and not getting data fed fast enough.

I might suggest contacting MOTU tech support and seeing what they say about the card you are currently using.

I was looking for something regarding using a firewire card like that and if there were any issues. I don't have time to look at the moment but I am now thinking that the card or how it communicates might have some part in it.

Since: Apr 06, 2009

Apr 06, 2009 09:28 am

I am wondering what if anything has been figured out with this issue? I have been fighting the same issues here at the college I work at. I listened to the sample and recognized the glitches right away. SOunds so familiar. I am running an HP with vista home premium 64 bit SP1. 2.20ghz AMD phenom 9500 quadcore with 5gb of ram. Nvidia geforce 9400 displayadaters (1 on board and one pciexpress card) agere 1394 host and texas instruments 1394 host. I was running with the on board firewire and thought that may be the problem so I purchased aPyro/AV turbo 1394b PCIe card. It has both 1394 a and b on it.

Some of the trouble shooting we have gone through:
The 896 HD was fine on our old win 2000 system. Updated to this system and began to have problems. After turning Vista into a virtual XP machine by turning all Vista new features off still had problems. Installed firewire card still problems. Here is were it gets interesting.

Bought an 896 (not HD) on ebay installed and it works fine. (It doesn't support cuemix) playsback for hours no glitching. Began to think maybe cuemix was the problem. I pulled an 8pre I have for protable recording and installed it. Ran a recording session and played back for hours using cuemix no problems. Begining to think it is the 896HD.

Took the 896HD and hooked it up to a vista laptop. Major glitching! This laptop I have used with the 8pre without problems. I hooked the 896HD up to an xp bow and laptop no glitching.

The 896HD, 8pre, and 896 are all using the same firewire cale plaugged into the same bus ports and all plug directly into power not using the firewire bus to power them.

Thanks for any help you can give on this one!

Since: Dec 04, 2007

Apr 06, 2009 12:35 pm

IMO, that's really starting to sound like shitty Vista support to me. Possibly in the original poster's situation as well. That's still the major reason I'm using XP to this day. (that and my compy is a bit dated) Try doing a fresh/clean installation of XP, get it up to SP2 or 3, and then see what happens. Backup all your data and important crap first though. I know it's a major PITA just to test possible causes, but when it comes to system stability, I don't play around.

Czar of Midi
Since: Apr 04, 2002

Apr 06, 2009 03:02 pm

Well your situation seems a bit more researched now though. Pinning it down to the HD unit is a big help. My guess then would be the driver support in Vista has something amiss.

And its difficult to find the blame. Is it the way the drivers were written by MOTU or is it something else in Vista that changed with the constant updates that is messing with the HD unit.

As for anything turning up here yet. I have not found a solution to this yet. I would suggest hitting up MOTU tech support and telling them exactly what you have listed here. That will give them a lot more to go on in finding any issues. They will want to know how updated the Vista version is and what version of driver you are running for the 896 HD.

Since: Oct 08, 2009

Oct 08, 2009 01:16 pm

Hey Cakeaudio
I've the same glitches with my 896hd motu since I've it.
I've contacted the motu tech and they didn't solved my problem...
I've a hp core2duo with a pci firewire TI chipset.
I use nuendo
have you solved your problems?

Since: Feb 17, 2010

Feb 17, 2010 01:51 am

I am having the same issue with Windows XP and Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 05)

However I have been working with the developer for the linux drivers with the ffado project and I don't have any of these issues in Linux (using the libffado-2.0-svn code.) The drivers work transparently as they should. The only thing missing is the footswitch (punch) which we will be trying to see if we can get to work fairly soon.

I have installed the latest MOTU drivers for Windows XP so either there are some issues with the officially supported drivers, or there is something that is happening in several versions of Windows (which I find to be a very frustrating operating system to work with for audio/video.)

A word of caution, I am using the latest Ubuntu Studio 64 but have had to recompile almost all of the audio software because I have compiled the latest FFADO and JACK2 and everything has to be recompiled to run with the latest JACK2.... so there are no user friendly linux versions out yet that you can get the 896HD to work with the stock drivers. But these fixes should filter up within a reasonable amount of time.

Related Forum Topics:

If you would like to participate in the forum discussions, feel free to register for your free membership.