Proteus X re-install Issues - please advise

Posted on

Member Since: Dec 04, 2007

So, here's the situation:

I had been using Proteus X for some time, about a year, and then I did something (not sure what) while using FL Studio, and boom. I either tried to start it up without the CD in the drive, or without the keyboard being turned on (as a dongle), or something along those lines to get a streaming error. Upon closing the program, and turning on/checking the devices, and restarting FL Studio, I get the same issue. Well, I didn't feel like playing nicely, so I uninstalled the software -completely- and attempted to re-install.

Everything is chugging along fine, until I get an error I-001 pop up at the end. The install.log shows it's having problems detecting the EXBBrowser.dll

Well, I went back, did a total clean, and even went so far as ripping the thing kicking and screaming from the allmighty registry itself. Every mention of proteus, every mention of EXB and other potential E-MU culprits. Rebooted, went in, Xboard Drivers install no problem (never had a problem with them) Then I reach for the Proteus X CD, and boom, same problem on trying to install.

I have contacted E-MU tech support, and got a response that they queried installshield about the matter, since I-001 was supposed to be an installshield error, and they told me to look for duplicate, or other installshield processes running concurrently. So I did, and in fact, on starting the setup program, there are indeed two setup processes running, one about 3MB and one about 16MB. So I killed the smaller process as the larger would stop the setup program itself as well as the other setup process. Unfortunately, no dice, same error, and I made sure to update that version of the installshield as well.

I wrote them back with what I had tried, so maybe they'll get back to me, but at this point, I'm starting to think just rebuilding XP fresh would be faster than tracking down this obscure anomaly with installshield. I swear it's situations like this that make me inch ever closer to going pure linux. ... (but I like my games too much) :P

Anyhoo, any ideas or insight into the matter would be appreciated.

Edit: system specs not that it'll help much I don't think.

AMD Duron Applebred 1.8Ghz
2.5GB PC3200 DDR RAM
SB Live! Platinum 5.1
ATI AIW 9600 graphics card
Motherboard: Chaintech 7NJL4 n-force 2
80GB Western Digital 7200RPM HDD

I'm almost certain something got buggered in XP itself, or maybe the installshield, meh, hopefully something can be figured out. :)

[ Back to Top ]

Ne'er ate 'er
Since: Apr 05, 2006

Feb 16, 2008 01:01 am

Reinstall the OS.

Mans reach exceeds his grasp
Since: Oct 23, 2007

Feb 16, 2008 04:14 am

I had the same issue when I installed GigaStudio LE from a disc I got that came with my Tascam US-144. I never got the LE version to work right, but I did buy the (half arse, useless upgrade, which had the same issues, but I fixed eventually.) What I found it to be, actually tonight was the solstice of my findings, is that it was a resource issue between my US-144 and the software. Probably not any help at all, but in hope, it could be.

I'd do what Herb said for sure, then contact E-Mu, (assuming I looked up the right thing,) and see about the 'earth' on that end of it if you know what I mean. Just trying to help, as always :)

Hope you get it figured out :)

Since: Dec 04, 2007

Feb 17, 2008 01:20 pm

Well, thanks for the idea, but I went ahead and rebuilt XP from the ground up. So, all is working so far, and Proteus X installed just fine. All my pertinent driver installations and other tools were backed up in one place, so it's easy to get those up and going again. So, I guess I'm back in business again. :)


I am not a crook's head
Since: Mar 14, 2003

Feb 17, 2008 01:26 pm

I just got Proteus X LE in a bundle with my MIDI controller keyboard. I've heard so many odd things about it that I'm kind of scared of what I have in store for me...gulp!

No problems yet though. It installed on 2 separate machines without any hangups (32-bit Vista and Win XP Home SP2). So far, so good.

Since: Dec 04, 2007

Feb 17, 2008 02:21 pm

Well, in all fairness, it probably wasn't an issue with Proteus X itself, it was probably me mangling something in XP in some way shape or form. I probably corrupted something in the installshield, or something along those lines, as this machine isn't a pure DAW box. I play some fairly heavy-duty games and such and access one of the machines at work through tunnelier on occasion to check/update/etc.

Anyways, though Proteus X can be a bit of a resource hog, it behaves itself pretty well in my experience. It did not seem to be unstable or glitchy to me, and worked pretty well. (I use FL Studio for the record)

Related Forum Topics:

If you would like to participate in the forum discussions, feel free to register for your free membership.