Strange 'Tascam US-122' problem... please help!

Posted on

Member Since: Aug 16, 2007

Hi guys, really hoping someone can help me here...

I have had my Tascam unit for about 18 months now, and have never really had any problems with it. But now, out of nowhere, it does not seem to be properly recognised by my PC.

When I turn on the computer with the US-122 attached via USB, a grey box appears saying 'if an installation CD came with this product, please insert it now'. As the programme has been installed for 18 months, I just tried swapping the USB cable instead. But when this didn't work, I tried inserting the installation CD when instructed and the following message appeared:

Tascam US-122 (firmware download)

'Has not passed Windows Logo testing to verify its compatibility with Windows XP.

Continuing your installation of this software may impair or destabilize the correct operation of your system immediately or in the future.

Microsoft strongly recommends that you stop this installation now and contact the hardware vendor for software that has passed Windows testing.'

I am tempted to uninstall and start from scratch, but also worried about losing the device altogether..? Any advice??

[ Back to Top ]

Since: Jul 27, 2007

Aug 16, 2007 09:37 am

I don't know what a "Tascam US-122" is, but it looks to me like the (firmware download) is the problem. If the unit or software has some sort of auto-update feature, it's just this latest update that XP doesn't like.

However, just because the firmware update hasn't been "Windows Logo Tested" doesn't mean it's going to mess up your system. Chances are, if the device worked properly for 18 months, it will most-likely continue to work properly after the update, but there are always risks.

If it were my computer, I would go ahead and install the firmware update, but it's not my computer, so if you're unsure about this, try using the XP compatibility wizard to run the device under an earlier version of Windows (2000 perhaps?)

Good Luck

Chief Cook and Bottle Washer
Since: May 10, 2002

Aug 16, 2007 09:40 am

The Microslop series of warnings are simply saying that Microslop has not tested the Tascam software themselves. Try going to the control panel/add remove programs and remove the tascam software. Then reinstall the Tascam software from the cd per instructions with the Tascam unit.

Since: Jul 27, 2007

Aug 16, 2007 10:13 am


If you were satisfied with your Tascam for the past 18 months, do what Walt suggested.

This will get you back to where you were before the Tascam software downloaded a firmware update.

You should then turn off any auto-updating features of Tascam, so that your problem doesn't re-occur later.

Since: Apr 03, 2002

Aug 16, 2007 10:20 am

That warning just means Tascam didn't pay an extortion fee to Microsoft to mark their drivers as "certified" by MS. It's not a problem, and honestly, MANY, MANY driver installs will say that, because the company would have to pay that extortion fee for every single driver revision as they release updates and revisions.

Don't worry about it.

Since: Aug 16, 2007

Aug 16, 2007 10:47 am

OK cheers guys.

I think my main concern was that this seemed to happen for no real reason, i.e not due to any upgrade or because I was fiddling with any cables etc. I should also probably mention here that my PC isn't hooked up to the internet either!?

But I'll try uninstalling and reinstalling and see what happens.

Thanks again, much appreciated.

Prince CZAR-ming
Since: Apr 08, 2004

Aug 16, 2007 01:46 pm

I have one of those, and yes, the drivers aren't certified, but not a problem either.

When I first got mine, it did that "load drivers from CD" thing, a few times. It's been smooth since.

I think it might have found the drivers on the PC, but I also may have had to load from CD. I can't remember. Don't know what caused it either, but oh well =).

Related Forum Topics:

If you would like to participate in the forum discussions, feel free to register for your free membership.