Macbook and Sonar 6 Problem

Posted on

Member Since: Apr 03, 2007

Hi all, I recently installed sonar 6 on my macbook with the help of bootcamp. I think there's a problem with the sound card in the macbook (sigma tel something) not being compatible with sonar as I can't seem to playback anything in sonar. I hit the space bar and it doesn't move. Also, sometimes when I start sonar, it tells me that the sound card is not compatible or it is being used and I am given options to either disable or use anyway. I'm really lost here. Was really hoping to be able to do my editing on the go.

Anyone knows what the problem is? Please help! Apparently, the macbook soundcard is good enough to run on logic so I don't see why it can't run on sonar.

[ Back to Top ]

Mans reach exceeds his grasp
Since: Oct 23, 2007

Feb 02, 2008 01:57 pm

Should be a simple fix really.
1)In Sonar, choose to use the audio card anyway.
2)Then go into options-audio, and select "Share audio drivers with other programs."
3)In Options-Audio, click on the drivers tab and make sure the Sigma Tel is checked on for both your ins and outs.
4)Close out Sonar and re-open and it should be smooth sailing from there.

If if still doesnt work, make sure you dont have any other applications running that could be using the sound card, such as iTunes, WinAmp, even internet browsers can steal it. After you've disabled the other audio programs, go back into Sonar Options-Audio and uncheck the "Share audio drivers with other programs" box. This will keep the drivers to Sonar and not let any other programs use it.

On a side note, make sure that you're booting into BootCamp from a fresh boot- power the computer all the way down before booting in BootCamp. This way you can be sure that there are no OSX programs occupying the sound card through background services. Keep us posted, and we'll walk you through your latency issues, cause you'll have problems with a Sigma Tel.

Since: Apr 03, 2007

Feb 02, 2008 04:11 pm


Thanks for the reply. I got it fixed by changing the driver type to MME instead of WDM. Strange thing is that when I run dxdiag, it says that the sound card is a wdm card. First time I'm running a MME, wonder if there are any problems with MMEs.

Anyway, as for latency, i changed it to 20.0msec and it ran fine. Hope I don't run into anymore problems. Thanks again!

Mans reach exceeds his grasp
Since: Oct 23, 2007

Feb 02, 2008 09:07 pm

Cool :) 20 ms of latency is pretty bad, but if it's working for your needs, then that's all that matters. If you ever find you need lower latency, you could always try ASIO4ALL, which is a different kind of driver that will slash your latency down big time. Here's a link:

After you've installed it, you just go to where tou changed your driver to WDM and switch it to ASIO. :)

Since: Sep 25, 2009

Sep 25, 2009 12:41 pm

I have the same problem. When i activated MME driver when i want import an audio file... there's an error directshow 80000241 or something like that. anybody know this problem and know solution??? sorry for my english im spanish

Czar of Midi
Since: Apr 04, 2002

Sep 26, 2009 12:25 am

The solution is to not use the MME driver. That is the worst driver as it is only a driver emulation that is a generic driver that is used with all sound cards for windows.

Switch to the WDM or ASIO driver and you should be good to go.

Related Forum Topics:

If you would like to participate in the forum discussions, feel free to register for your free membership.