Router problems:

Posted on

Member Since: Dec 04, 2007

Have been using a Trendnet TEW-633GR router for several years, no problem. I'm starting to wonder if it's dead.

Over the weekend, (coincidentally, after installing a new video card) I noticed major drop in network speeds. I stayed up all last night testing retesting, researching, resetting to factory default, and nothing, nada. I swapped the cable between the router and the cable modem, no improvement.

So, here's what's happening, and what I did to try to test. Wireless has the same problems, but my primary test point is from my desktop which is on a -wired- connection.

Plugged directly into the modem, I get normal speeds. shows around 25 Mbps down, and about 1.5 Mbps up.

Going through the router, it drops drastically. Though, if I turn off both the router and the modem for a couple minutes, then turn them on, I briefly, maybe for about a minute, get normal speeds through the router. But then it starts slowing to a trickle in less than 5 minutes.

I can ping the modem, no problem. I can ping the router, no problem. But, sometimes when I ping, I get some packets that time out.

I have tried disabling QoS (WISH), I have tried disabling all firewalls temporarily, I have reset the router to factory settings, and ensured it is running the latest firmware, and I have tried removing the router from the network.

I think the router is the problem, but I don't know why. I didn't change anything or start mucking around until I saw the drastic speed decreases. I thought it might be a problem with the ISP, but it's not since the speeds directly through the modem are good. So, it has to be the router.

If I'm -really- lucky, I might get about 1.3 Mbps download speed right now. Usually it's closer to 0.10 Mbps download speed.

There are no strange devices on the network, and right now, the only computer on the network is my desktop. no change.

I briefly reconnected my wireless-n laptop to the router, and I am noticing it has 0 bars on the signal strength for some reason. Before this all happened, it had full bars. I have not changed the positions of either device.

I think I'm gonna go bald from pulling my hair out over this. We might just go out and buy a new one tomorrow evening when we go to see the lego movie.

[ Back to Top ]

Since: Dec 04, 2007

Feb 10, 2014 03:20 pm

Double post, but an addendum.

Since the problem is outgoing, I'm wondering if somehow the router's routing/switching mechanisms became corrupt or broke down.

I know over about the last month, my wife's watching of hulu has been a little problematic, as it seems like hulu keeps freezing every couple minutes, like it's buffering.

I just assumed it was mediacom being the problem and it would clear up. Maybe that was the early warning sign that the router was about to go belly up instead!

through I'm now seeing a download speed of 0.01 Mbps !!!! this is way worse than it was when I was testing last night!

I think it's dead, Jim!

Since: Apr 03, 2002

Feb 10, 2014 03:24 pm

From what you have said, sounds like your router is due for replacement, packet loss when it's in the chain, none when it's not...seems pretty cut and dry...I wouldn't pull any more hair out, just replace a failing router and be glad you got several years out of it.

Since: Dec 04, 2007

Feb 10, 2014 04:05 pm

Thanks dB. That's what I was afraid of. I guess we'll hop down to best-buy tomorrow, and see what they have.

Probably end up getting a decent netgear router.

Since: Apr 03, 2002

Feb 10, 2014 04:06 pm

I've been uber happy with the Belkin router I bought a few months back...

Since: Dec 04, 2007

Feb 12, 2014 01:48 am

Ended up getting a Linksys EA6300 (showed the wife some ratings I had saved on the tablet while we were standing in front of the shelves at the store) We both considered getting the wireless AC spec for the sake of future proofing a bit. It's a simultaneous dual-band, so can support 2.4 and 5G bands concurrently.

So far, seems to be working okay. I'll keep an eye on it, though. I have disliked Linksys in the past, but that was before they were bought by Cisco. (my wife's old Linksys router, a little blue one int 2004/2005, only lasted a few years, had constant disconnects, and just sucked in general)

Anyway, it's working decently so far.

Since: Dec 04, 2007

Feb 12, 2014 08:55 pm


Hmmm, it could be the cable modem/line after all.
I logged into to check the cable modem diagnostics, and the signal ranges look good from what I read.

So yeah, I plugged directly into the cable modem, leaving the new router out of the equation, and initially I was getting stable 25Mbps speeds....but half an hour later, and I'm getting like 2 to 3 Mbps. :P

Time to call Mediacom. >_<

Started forum correspondence. So, he said there were some signal spikes that were out of range coming from us, and suggested checking the coaxial cable, making sure it didn't have corrosion on it, and make sure it wasn't behind an adapter or splitter.

I had a new cable from before I moved, so I just replaced the cable, and gave him some additional info so he could check some other things.

So far, it's been about half an hour, and the speeds are looking better. I know I said that before, so I'll go knock on some wood.

I'm going to give it about another half hour or so, then try adding the router back into the chain.

One thing I did notice, was that the bit error rate before I swapped the cable was at about 0.42%. I just checked the modem diagnostics page again, and it seems to have decreased steadily, and is holding at 0.18%

But yeah, gonna monitor this. Worst case scenario, the old router still works okay, and I now have two routers that I could get creative with. Maybe have a separate intranet behind the switch strictly for home recording studio purposes, or set up an inner and outer router boundary. xD

Updated Update:
Okay, I found the root cause for all the problems. The linksys was probably a decent router, but I wasn't happy with it, or its interface and how it controlled stuff, so I exchanged it.

The new new router is an Asus RT-N66R. I am liking the config options on this one wayyyyyy more. So, initially, I had the same problem as I did with the linksys.

The root cause, from all my testing, was that the router was probably just emitting too much EMI, and wasn't shielded well enough. With the linksys, I noticed things improved a little when I moved the router about 5-6ft. away. But speeds were still very erratic.

The Asus exhibited the same issues, though maybe not -quite- as bad as the linksys. I was getting 5 to 6 Mbps, but it was still not good, and the bit rate error kept climbing.

I don't have a cable long enough to move the router far away, so what I did was put my D-Link switch between the modem and the router, and moved the router out by the TV in the other room.

This has worked beautifully....well, except for one cable that is on the floor, and two cables that kinda hang off the bookshelf a bit. :P

But it's been 6 hours, speeds and everything are stable, and I'm getting good speeds, and yeah. So I think the root cause was just interference from either the wifi radio or the router itself adding noise to the modem or coaxial line. They really need to shield these things better, especially what with more powerful wifi radios/antennae. :P

Anyway, problem is officially solved.

Related Forum Topics:

If you would like to participate in the forum discussions, feel free to register for your free membership.