Alesis Multimix Firewire 8 Install Help Please!

Posted on

Member Since: Mar 21, 2009

Hello out there... so I get this Multimix Firewire 8 today from a dude on craigslist. I get home after buying a $30! firewire 400 to 800 cable to link it up to my macbook pro. I downloaded the drivers from Alesis the software was installed successfully...BUT... when I open up the firmware update all I get is a window that says: Update Current Firmware
Vendor Alesis Vendor none
Product MultiMix Firewire Product none
Version 2.0 Version none


Waiting For Devices

The Update is "button" is grayed out but the Cancel button has darker letters and is functioning. I let it sit for more than several minutes to see if it would activate but no go. Anybody ever encounter this or know how to fix this? Oh yeah I tried a different firewire cable which I know for a fact works and still no show.... Busted!?

[ Back to Top ]

Czar of Midi
Since: Apr 04, 2002

Mar 21, 2009 09:29 pm

So it isn't recognizing the device or is it? Have you checked to see if it is in a device list?

I do agree though it sounds as if the unit is not communicating with your Macbook.

I have not seen this one yet, I might suggest contacting Alesis tech support on this one. They are pretty good at getting back with problem pieces of gear.

But you could be correct in assuming the gear might be bunked as well. I normally try a piece of gear out before plunking any cash out to a stranger on things.

Related Forum Topics:

If you would like to participate in the forum discussions, feel free to register for your free membership.