Installing M-Audio Fast Track

Posted on

Member Since: Nov 24, 2007

I am a novice when it comes to recording.

I need some one to walk me through the installing of the Fast Track. I have no manual so I am only going by the user manual which I downloaded from AVID.

I plugged in the unit to the USB port and the 'puter found new hardware. From the manual it indicates that I do not have to download drivers if used for basic operation with XP. I plugged my guitar into the jack and did the same for my earphones but I hear nothing.

From here I do not know how to proceed. Do I have to change anything in my soundcard?? Any help would be appreciated. Thanks in advance.

[ Back to Top ]


Eat Spam before it eats YOU!!!
Member
Since: May 11, 2002


Dec 12, 2007 08:10 pm

um... try doing:

start->control panel->sound device (or something like that) then in one of the tabs it should say 'default playback device' and default recording device'...etc... try setting the those to the fasttrack...

Eat Spam before it eats YOU!!!
Member
Since: May 11, 2002


Dec 12, 2007 08:12 pm

oh wait... guitar... um... make sure that the input is switched from 'line' to 'instrument' ... usually it's a button... might be marked 'hi-Z'

Prince CZAR-ming
Member
Since: Apr 08, 2004


Dec 12, 2007 08:16 pm

Which fastrack, M-Audio shows a fastrack pro, and a fastrack USB.

It shows drivers for the FT USB:
www.m-audio.com/index.php...32912&OS=15

and for the FT pro:
www.m-audio.com/index.php...1ae81&OS=15

I would certainly download the correct driver first.

DL and then install it, then you should get a control panel from M-Audio, that represents your device.

Once that's done, I would disable my onboard soundcard, as you don't want it to interfere with easy operation of the FT.

See if you can get those steps going, and poke around some, and report back here. We can keep pushing when that's working.

re-reading, i'm curious as to what windows told you after it found new hardware. Did it say the hardware was installed and ready for use? or did it keep prompting you for drivers?

Anyway, try the drivers, and we'll go from there.

Eat Spam before it eats YOU!!!
Member
Since: May 11, 2002


Dec 12, 2007 08:33 pm

most usb audio devices are a third party driver (Core Audio I think) and are included in windows as a generic driver.

Member
Since: Nov 24, 2007


Dec 12, 2007 10:10 pm

After it said that it found new hardware it said the files were being downloaded. Fast Track then appeared in Control Panel. By opening it the drivers can(will) be downloaded. Like I said in my initial post the instructions by AVID said I did not have to download the drivers if I am using it for a basic application. Whatever that means??

I will try the suggestions offered above. I really appreciate everyone's input. Thanks!

Member
Since: Nov 24, 2007


Dec 12, 2007 10:19 pm

When I went to Sound there was only one choice in Sound Playback Default and it was SoundMAX Digital Audio.

Guess I should download the drivers????

Maybe M-Audio Fast Track will appear??

Mans reach exceeds his grasp
Member
Since: Oct 23, 2007


Dec 13, 2007 04:07 am

It should have come with install discs. I just went through this with my Tascam US-144; I ran back out to the dumpster when I realized it had firmware that came with it.
www.m-audio.com/index.php...&tab=driver

Go to that link, find your driver update ( and if needed, firmware update) and install them. If you're computer savvy at all, try to uninstall the old drivers before installing the new ones. No big deal if you can't though, the new ones should over-ride the old ones.

A word of caution though, there doesn't seem to be a 'good' driver set for Windows Vista. So if you're using Windows Vista, you might have to wait for the driver update. :(

Best of luck, and I'll be watching this thread in case you have any other problems/ questions.

Hold 'Em Czar
Member
Since: Dec 30, 2004


Dec 13, 2007 04:26 am

ya say you don't hear yourself playing, i'm curious if your software can still hear it and not you....have you tried recording a 'sample' bit and still getting no signal? regardless if you can or can't hear it in the headphones.....this is the first fork down the troubleshooting road.

Member
Since: Nov 24, 2007


Dec 15, 2007 10:45 am

Problem solved!!Figured it out on my own. What a dumbarse I am. LOL!

Thanks everyone for your input.

Happy Holidays!

Cone Poker
Member
Since: Apr 07, 2002


Dec 15, 2007 05:59 pm

would you mind posting what you did to fix it in order to have it on here in case someone else has the same problem?

And happy holidays to you as well.

Member
Since: Nov 24, 2007


Dec 16, 2007 04:15 pm

This is Lengthy!

Despite what User manual says Drivers will have to be downloaded for it to function properly. Also do NOT connect FT to USB port until drivers are downloaded!
1) Go to www.m-audio.com/index.php...5&keywords=
2) Click on Drivers at top of page.
3) Under Drivers and Software Search--USB Audio Series...Fast Track USB...Windows XP
4) Download Fast Track WDM 5.10.00.5080v2.exe
5) When it is installing ignore any mention of software not passing Windows Testing but click on Continue Anyway.
6) Click Finish when asked!
7) Check in Control Panel to see if it is present!
8) If it is connect FT to USB port and found hardware is indicated and Icon in Running Programs should appear--Red circle with white > sign.
If using guitar hook into receptacle for guitar and make sure input level is in out position. To hear sound through desktop speakers unhook from computer. I used an adapter from Radio Shack for speaker cord and cord to fit into stereo/mono outputs.
You will have to tweak controls on the mix and output and turn microphone down to get proper sound.
If you have problems go to FAQ. It is usually very helpful.
HOPE THIS WILL AID ANYONE LIKE ME WHO FOUR DAYS AGO DID NOT KNOW SHEET ABOUT THIS PREAMP. LMAO

Czar of Midi
Administrator
Since: Apr 04, 2002


Dec 16, 2007 07:29 pm

Thanx Jerry, that will be very helpful to the next guy coming in with that problem.

Member
Since: Jul 22, 2008


Jul 22, 2008 05:12 pm

Ok, I am reading most of this, so far my MAudio FT USB is working but I didnt install the drivers just yet. I had to uninstall earlier because the same thing has happened. I am using a lap top , Win XP, not sure though which service pack, if any. I tried before with all the software that came with it but not this time. When I go into the sound properties and I try to switch the recording porperty to M Audio and leave the playback at the Sigma sound card and press ok, it still changes my play back to M Audio. SO basically I hear no play back but I can record. I am able to save my file then hear it. I can hear other audio like MP3's and other files but i cannot monitor my recording nor hear it in play back on my multi track software, I am using NTrack btw. I have just downloaded some new software for M Audio USB and I'm going to try that. Should I disable the Sigma sound card that is on the lap top?

Czar of Midi
Administrator
Since: Apr 04, 2002


Jul 24, 2008 05:24 pm

I usually dissable the onboard sound card yes. It is more a precaution most times, but it prevents any conflicts from happening.

Member
Since: Jul 30, 2008


Jul 30, 2008 10:53 am

cubase le4 only lets me add 8 tracks of instruments do i have to upgrade to use more instrument trax.

Administrator
Since: Apr 03, 2002


Jul 30, 2008 10:57 am

yeah, an upgrade to a full version would give you, I believe, unlimited tracks.

Member
Since: Jul 30, 2008


Jul 30, 2008 11:04 am

thanks

Czar of Midi
Administrator
Since: Apr 04, 2002


Jul 30, 2008 09:35 pm

Thread jacking is not a good thing.

Especially when you do it in multiple threads.

Your answer is in your original thread.

Member
Since: Jan 17, 2008


Aug 05, 2008 01:36 pm

Here's how I set up my fast track pro.

(Oh by the way, M-audio said their drivers don't work with media center edition. For some reason, the FTP works for me, but maybe I'm just lucky.)

Anyways, first keep the device UNPLUGGED from the computer. Download the latest drivers from the M-audio website ( do NOT use the ones that came with it)
install it, plug the fast track in once it tells you to(or if it doesn't, after the install).

Then, disable your on-board soundcard.
(control panel > system > hardware > device manager > sound devices > right click your soundcard and click disable)

Now, plug your monitors\speakers\headphones into the back of the fast track.

(note: I could never get headphones to work properly with my fast track pro. I just use computer speakers through the TRS output 1 and a 1/8 to 1/4 adapter.)

Hope that helps.

EDIT: LOL, didn't notice he figured it out himself. ._.

Member
Since: Sep 12, 2008


Sep 12, 2008 05:59 am

Hi All,

I got the fast track usb the other day and stupidly connected it before installing the Vista drivers. When I connect it, the m audio control panel does say that it is connected but I don't seem to be able to get anything when I play my guitar! I think it's probably because I connected it beforehand, so could someone advise me on how to properly get rid of all the drivers installed? Or if anyone thinks it's not because of that, please let me know.

Many Thanks,

Aaron

Czar of Midi
Administrator
Since: Apr 04, 2002


Sep 12, 2008 10:51 pm

You need to use the un install that is listed under M-Audio first off. Then you need to go into the registry and un install anything that pertains to M-Audio or M-Audio devices.

Then follow the install instructions carefully and you should be good to go.

Member
Since: Oct 01, 2008


Oct 01, 2008 12:59 pm

hi just got a m-audio fast track usb

using an advent laptop with windows xpsp3
i have installed the drivers (the up to date ones from the web site)
disabled the realtek internal sound card
i plug my m-audio in and have a blue light on the unit, and when i plug my head phones in i can hear my guitar as its coming through the unit so i know thats working all ok so far, i loaded the gt player express (also tried guitar rig 3 same symptons) however all i can hear is my dry sound i cannot hear any difference like the effect gt player express should be making, i changed the mix on the maudio device so half input half play back and tested a mp3 and could hear the mp3 and can also hear my guitar, im convinced its working and its me not doing anything, i checked the gt player express help and didnt find much to go on tbh
can any one help me? i know a previous poster had said head phones dont work for him unfortunatly i dont have anything else to plug into my maudio,
i have bought this product to allow me to record guitar parts i have cuebase but am about to learn how to use this as i have some friends who are quitek nowledgeable about cuebase/reason,
this is really anoyin me
thanks for any help

Member
Since: Dec 11, 2008


Dec 11, 2008 08:04 pm

Hi everyone,
Ive been reading everything here, and still aint got the solution for my problem... maybe someone can help me...

Problem:
Ive installed my fast track usb w/ guitar rig 3, and they work great together. However, when i try to play along w/ an mp3 player or any kind of audio file, the guitar sound disappears...

Same thing happens when i try to record my guitar on Cool Edit 2.0. /the effects from the guitar rig are disabled when any other audio thingy is played...

Is there a way to make everything together? could anyone please show me a step by step routine?

Related Forum Topics:



If you would like to participate in the forum discussions, feel free to register for your free membership.

Processing Request.
Have Patience, Don't Keep Clickin'