audiophile 2496 latency help

Posted on

Member Since: Jan 18, 2003

hey i just realized that whenever i change the latency in my audiophile's screen (via the windows control panel, which brings up the soundcard's meters and stuff) it immediately reverts back to 700-something. how can i get it to stick? why wouldn't it persist?

i'm getting some clicks and pops as i try to run my drums. i want to raise the buffer size, right? can someone put that tradeoff into general terms again real quick while you're at it? i thought it was lower buffer size less latency and less memory used, higher buffer size and more memory used and more latency but better sound quality, right?

what range should i be in with the buffer settnig do ya think?

[ Back to Top ]

Since: Jul 02, 2003

Mar 11, 2007 01:25 am

Don't you have the M-Audio Delta control panel installed? You shouldn't even have to use Windows Control Panel. You should access the control panel from within the DAW/Sequencer software that your using as that is what is probably changing it back as soon as you start the program.

If your getting clicks/pops with 768 sample buffer you're probably not going to get much better results going higher. If you're working with other tracks with effects on them while trying add the drums, either remove the effects (best) or freeze the tracks to free up some CPU. I usually run 128-256/samples while recording and around 512/samples when mixing.


Since: Jan 18, 2003

Mar 11, 2007 03:44 am

i am using the m-audio panel. just wasnt speaking clearly. i get to it through the control panel in windows, thats all

in the m-audio card panel, i have 'do not let audio programs screw with my settings' checkmarked. so why would something be reverting the settings if that is checked?

so 768 is a high buffer setting? yes, i get clicks and pops. mild ones. but i just want the best settings. you wouldn't go higher? i shall have to read all about the buffer settings tonight

Since: Jul 02, 2003

Mar 11, 2007 04:20 am

I think that setting only applies to the mixer and the routing panel. Your audio app will set the latency buffer to whatever is set in the app, and that's where you should normally bring up the m-audio panel to change your settings. One other thought, if your not using the ASIO driver I don't think the m-audio panel will change the WDM buffer settings those would be set in audio app.

You can try setting the buffer higher but if 768 isn't high enough my experience has been that setting it higher isn't going to help, though of course it's worth a try.

Since: Jan 18, 2003

Mar 11, 2007 04:29 am

any idea how to find the latency option in cubase? i know ive seen it but cant seem to find it now

Since: Jul 02, 2003

Mar 11, 2007 04:55 pm

I'm not familiar with Cubase, I would assume it would be under audio or device options somewhere.


Czar of Midi
Since: Apr 04, 2002

Mar 15, 2007 10:11 pm

forty, I think its called preferences/audio in in Cubase though I'm not sure. Otherwise it is options/audio and you should find the buffer there. It will be called either latency or audio buffer.

I agree with OD though as well. I rarely have to set anything above 128 or 256 while recording. I know with the ESI stuff I can hit 64 which gives me about 1.7ms of latency. With the UX-2 running ASIO I can hit about 3ms running at 128.

Like OD though I will set it up to 512 during mixing just to be safe and insure no snafu's.

I would as well double check to make certain you have the absolute latest driver revision. If I'm not mistaken there was a slight flaw in the previous release or the one before it. Don't remember for sure though.

Related Forum Topics:

If you would like to participate in the forum discussions, feel free to register for your free membership.